As of June 26, 2018, Vector Security will no longer support Transport Layer Security (TLS) v1.0. TLS is a cryptographic protocol used to establish a secure communications channel between two systems. It is used to authenticate one or both systems, and protect the confidentiality and integrity of information that passes between systems.

What does that mean?

  • Browsers that don’t support TLS v1.1 or v1.2 will not be able to view https://www.vectorsecurity.com. That includes our customer portal.  If you pay your invoice via our online customer portal, you will no longer be able to do so.

  • Desktop browsers that will work after June 26, 2018:
    • Internet Explorer: Version 11 and greater
    • Firefox: Version 27 and greater
    • chrome: Version 30 and greater
    • Opera: Version 17 and greater
    • Safari: Version 9 and greater (must have OS X 10.9 or greater installed)
    • Edge: Any version

  • Mobile browsers that will work after June 26, 2018
    • iOS Safari: 5 or greater (must have iOS 5 or greater installed)
    • Android OS: 5.0 or greater

If you are not sure what browser or version you are using, visit www.whatsmybrowser.org.

In order to view our website safely, if your browser is not listed above as being one that will work, please download one of these free and up-to-date browsers to ensure you’re using the latest and best security.  Out-of-date browsers are a security threat and are vulnerable to viruses and malware.

Click the web browser you’d like to download:

 

chrome

Firefox

Internet Explorer

Opera

Safari

 

Related articles:

Are you ready for June 26, 2018?
Microsoft no longer supports Internet Explorer 8, 9 and 10
Internet Explorer 8, 9, and 10 Die on January 12, 2016
TLS/SSL support history of web browsers